Import data from Excel

Hi, I am trying to import a simple table from Excel (2 columns : country_iso and country_name).
I have this error “too many retries” 816079f7-d68c-483c-99b8-0e6492f75a7f

If I try to load up to roughly 15 lines it works fine. If I try to import 25 I have the error.

Does the Postgres table already have data in it? Sometimes these failures happen when there’s a schema mismatch

there are data. I have tried to upload few lines (say 3) and it worked. Then another 10 and it works. Now I have 160 rows after various import tests (uploading blocks of 5-15 lines at a time).
Basically it seems there is a bug limiting the upload of more than a certain number of lines (ie 25 lines not working)

I confirmed there is indeed a schema mismatch on several rows that is yielding this error. The bug is not showing you the true error, we can handle millions of rows and multi-gigabyte files. I’ll reach out to you with specifics.

mmm this is very strange…
Namibia does not look null
Maybe I should use csv instead of pure Excel?



I generally don’t recommend posting data on our site but this is probably safe.

It looks like our inference engine is interpreting “NA” as null, which is a very common shorthand for indicating null. Like “n/a”. Our inference engine is not changeable. But, you can always upload the data yourself using the COPY command directly.

Great thanks!
Mistery solved… inserted manually Namibia and rest worked fine